...

funcion si y buscar

by user

on
Category: Documents
4

views

Report

Comments

Transcript

funcion si y buscar
Excel:
SI y BUSCAR
1
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
¿Por qué?
• La función SI
• SI (expres_lógica; valor_A; valor_B) = SI(Condición; valor_si_verdad;
valor_si_falso)
• Ejemplo: Calcular el porcentaje de retención a aplicar en función del valor de los
ingresos que se encuentran en C9.
=SI(C9<=A3;B2;SI(C9<=A4;B3;SI(C9<=A5;B4;SI(C9<=A6;B5;B6))))
Recorre las
condiciones
una a una y
cuando se
pasa, se
queda con
la anterior
2
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
¿Por qué?
• ¿Cuando no vale? Según va aumentando el tamaño de la tabla ⇒ se hace impracticable
=SI(C10<=A3;B2;SI(C10<=A4;B3;SI(C10<=A5;B4;SI(C10<=A6;B5;SI(C10<=A7;B6;B7))))
3
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
Solución: Búsqueda en tablas de datos
¿y si la tabla tiene 500 filas de datos? ⇒ hay funciones para resolver el problema
• Buscar
• BuscarV
• BuscarH
• Índice
• Coincidir
4
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
Solución: Búsqueda en tablas de datos
• Buscar: sirve para encontrar un valor en una tabla, sin importar las dimensiones de la
misma
Devuelve un único valor. Hay que decirle en qué rango realizar la comparación y en
qué rango está el valor.
Buscar(Condición; rango_comparación;rango_valor)
Buscar(C10;A2:A8;B2:B8)
5
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
Solución: Búsqueda en tablas de datos
• Buscar: también sirve para datos textuales
Buscar(Condición; rango_comparación;rango_valor)
Buscar ("Ana Álvarez"; A2:A6; B2:B6)
Buscar ("Sergio Zurdo"; A2:A6; B2:B6)
• ¿Cuándo falla? ⇒ si datos textuales, deben estar ordenados
Habrá que ordenarlos
6
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
Solución: Búsqueda en tablas de datos
• BuscarV y BuscarH: sirven para realizar búsquedas en grandes tablas, sin ordenar,
normalmente empleando una clave
BuscarV (Clave; rango_tabla; número_ col _valor; ordenado)
BuscarH (Clave; rango_tabla; número_fila_valor; ordenado)
• Clave es el valor por el que se identifica a los datos de la tabla.
• Rango_tabla es el rango de celdas que contiene la tabla de datos.
• Número_fila/col_valor indica el orden que ocupa en la tabla la fila/col que
contiene el valor que se busca.
• Ordenado es una variable lógica (0 o 1) que permite elegir si la coincidencia del
valor buscado ha de ser parcial o total. Para que sea total 0, aproximado 1.
7
Parte II.II.- Búsquedas, tablas y Bases de Datos
•
1.1.- Búsquedas en tablas de datos
EJERCICIO 1: En el departamento de ventas de la empresa RUMOROSA, se discute la polí
política de comisiones a pagar
a sus comerciales. Calcular cual serí
sería la comisió
comisión que percibirá
percibirá cada vendedor en los siguientes casos:
•
Caso A:
1. Si el importe de la venta es inferior a 30.050,61€
30.050,61€. Percibirá
Percibirá un 10% sobre ventas
2. Si el importe de la venta es igual o superior a 30.050,61€
30.050,61€. Percibirá
Percibirá un 15% sobre ventas
•
Caso B:
1. En las zonas Norte y Sur se pagará
pagará una comisió
comisión del 8%
2. En las zonas Este y Oeste se pagará
pagará una comisió
comisión del 14%
•
Caso C:
1. En la zona Sur se pagará
pagará una comisió
comisión del 8%
2. En la zona Norte se pagará
pagará una comisió
comisión del 12%
3. En las zonas Este y Oeste se pagará
pagará una comisió
comisión del 15%
•
Caso D:
1. Si la venta realizada es inferior a 18.030,36€
18.030,36€ se percibirá
percibirá una comisió
comisión del 7%
2. Si la venta realizada está
está entre 18.030,36€
18.030,36€ y 36.060,73€
36.060,73€ se percibirá
percibirá una comisió
comisión del 10%
3. Si la venta realizada es superior a 36.060,73€
36.060,73€ se percibirá
percibirá una comisió
comisión del 15%
La hoja Excel en la que se realizará
realizará el ejercicio será
será de la forma:
8
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
La hoja Excel en la que se realizará el ejercicio será de la forma:
9
Parte II.II.- Búsquedas, tablas y Bases de Datos
•
1.1.- Búsquedas en tablas de datos
Caso E:
En funció
función del intervalo en el que se encuentre la venta, se podrá
podrán percibir distintas comisiones. Los
intervalos y las comisiones asociadas se encuentran en la tabla de comisiones
•
Caso F:
Los comerciales percibirá
percibirán una comisió
comisión en funció
función de la venta realizada (tabla anterior) y ademá
además cobrará
cobrarán
tambié
é
n
una
prima
extra
en
funció
ó
n
de
dicha
venta.
Utilizar
la
tabla
de
primas.
tambi
funci
INTERVALO VENTAS
•
COMISIÓN
INTERVALO VENTAS
PRIMAS
18.030,36€ o menos
5%
18.030,36€ o menos
150.25 €
Entre 18.030,36€ y 27.045,54 €
7%
Entre 18.030,36€ y 27.045,54 €
210.35 €
Entre 27.045,54 € y 36.060,73€
9%
Entre 27.045,54 € y 36.060,73€
270.46 €
Entre 36.060,73€ y 45075,91€
11%
Entre 36.060,73€ y 45075,91€
330.56 €
Entre 45075,91€ y 54.091,09€
13%
Entre 45075,91€ y 54.091,09€
390.66 €
Más de 54.091,09€
15%
Más de 54.091,09€
450.76 €
Caso G:
Si la venta es inferior o igual a 36.060,73 € se percibirá
percibirá un 10% sobre las ventas
En caso contrario usar la tabla de comisiones del caso E.
10
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
SOLUCIÓN del EJERCICIO 1:
11
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
SOLUCIÓN del EJERCICIO 1. FÓRMULAS:
12
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
Búsqueda en tablas de datos. Ejemplo con datos textuales
• EJERCICIO 2: Dada una tabla de calificaciones de alumnos, buscar a los alumnos que se
pide:
Decir qué nota ha sacado el alumno Abanda Hernández
Indicar a qué grupo pertenece el alumno Aceituno Gutiérrez
13
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
• SOLUCIÓN EJERCICIO 2:
=BUSCARV(A16;$A$2:$E$11;5;0)
=INDICE(E3:E11;COINCIDIR(A16;A3:A11;0))
=BUSCAR(A16;A3:A11;E3:E11)
Decir qué nota ha sacado el alumno Abanda Hernández
Indicar a qué grupo pertenece el alumno Aceituno Gutiérrez
=BUSCARV(A17;A3:F11;6;0)
=BUSCAR(A3:A11;A3:E11;1)
14
•EJERCICIO 3: Sea el siguiente catá
catálogo de productos informá
informáticos, con sus má
márgenes correspondientes. Rellenar el
siguiente albará
albarán buscando en el catá
catálogo el P.V.D. Y calcular el P.V.P. aplicando los correspondientes
correspondientes má
márgenes.
Calcular el IVA a aplicar y el precio final.
15
• SOLUCIÓN EJERCICIO 3.
=SI(C4="";"";C4*(F4+E4))
=SI(A4="";"";BUSCARV(A4;'EJER 3(CONT)'!$A$4:$D$16;3))
=SI(A4="";"";D4*BUSCARV(A4;'EJER 3(CONT)'!$A$4:$D$16;4)+D4)
=SI(E4="";"";REDONDEAR(E4*$D$21;2))
16
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
• ÍNDICE y COINCIDIR:
Son funciones para realizar búsquedas en tablas de texto en las que no es necesario que los datos
textuales estén ordenados. Índice: utiliza un índice para acceder a un valor a partir de una referencia o
matriz. Coincidir: Busca los valores en una referencia o matriz
• INDICE (matriz; núm_fila; núm_columna)
devuelve el valor de una celda o de una matriz de celdas determinada
determinada dentro del argumento ref.
• COINCIDIR (valor_buscado;matriz_buscada; tipo_de_coincidencia)
Valor_buscado:
Valor_buscado: es el valor que se usa para encontrar el valor deseado en la tabla.
tabla. Valor_buscado es el valor que
desea hacer coincidir en la matriz_buscada. Por ejemplo, cuando busque algú
algún nú
número en la guí
guía telefó
telefónica, estará
estará
usando el nombre de la persona como valor de bú
búsqueda, pero el valor que realmente desea es el nú
número de telé
teléfono.
Puede ser un valor (nú
(número, texto o valor ló
lógico) o una referencia de celda a un nú
número, a un texto o a un valor
lógico.
Matriz_buscada:
Matriz_buscada: es un rango mú
múltiple de celdas que contienen posibles valores a buscar. Matriz_buscada
Matriz_buscada puede ser
una matriz o una referencia matricial.
Tipo_de_coincidencia:
Tipo_de_coincidencia: es el nú
número -1, 0 ó 1 y especifica có
cómo hace coincidir Microsoft Excel el valor_buscado con
los valores de matriz_buscada. 1: busca el mayor valor inferior o igual al buscado. 0: encuentra el primer valor que
es exactamente igual al valor_buscado. Los valores en matriz_buscada
matriz_buscada pueden estar en cualquier orden.
17
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
• ÍNDICE y COINCIDIR:
Se suelen emplear combinadas: INDICE(matriz;COINCIDIR(valor_buscado;matriz_buscada;
tipo_de_coincidencia))
18
Parte II.II.- Búsquedas, tablas y Bases de Datos
1.1.- Búsquedas en tablas de datos
• EJEMPLILLO:
=BUSCAR("Ana
Álvarez";A2:A6;B2:B6)
=BUSCAR("Sergio
Zurdo";A4:A8;B4:B8)
=BUSCARV("Carlos
Segura";A2:D6;3)
=BUSCARV("Ana
Álvarez";A2:D6;4)
=INDICE(A2:A6;COINCIDIR("Jefe
sección";C2:C6;0))
19
Fly UP